Owncloud 8 Login Loop Fehler beseitigen

by | 6.06.2016 | daily IT, News

Laut Google bin ich nicht der Erste mit dem Problem eines Login Loop. Beim Anmelden am OwnCloud 8 Server landet man in einer Schleife. Den Benutzernamen und das Passwort eingeben, Anmelden klicken und… Alles von vorn. Die Anmeldung am OwnCloud-Server funktioniert nicht, es erscheint immer wieder die Login Seite. Nebenbei stellte ich fest, das der Android- und Windows-Client auch nicht mehr synchronisieren. Dort zeigt sich das Problem als Anmeldefehler.

Ganz am Anfang zweifel ich noch, ob die eingegebenen Daten wirklich korrekt sind.

-> Mein Vater sagte vor 20 Jahren mal zu mir: „Wenn du zu blöd bist, dir was zu merken, dann schreib’s dir auf. Ich mach’s schon 20 Jahre so!“

Aber laut meiner Onenote Aufzeichnungen sind die Anmeldedaten richtig. Und eine vernünftige Dokumentation ist gold wert, das zeigt sich dann bei der Lösung.

Nachdem ich den ssh und ftp Zugriff geprüft hab, fragte ich mal Tante Google. Aha, für diesen Fehler gibt es sogar einen Namen: Login-Loop. Aber die Google Antworten befriedigen mich nicht. Entweder treffen sie nicht auf mein Owncloud 8 zu oder es wird auf die Passwortwiederherstellung über die mySQL Datenbank mittels phpmyadmin verwiesen.

Also weiter: Immer wenn ich an einer Stelle nicht weiterkomme, hilft es mir die Situation aus einem anderen Blickwinkel zu betrachten. In diesem Fall war meine Überlegung, das das Problem eventuell gar nicht an OwnCloud 8 liegt.

Die Lösung des Ganzen:

Nachdem ich meine eigene Änderungshistorie durchgeschaut hab, fiel mir auf, das ich vor ein paar Wochen bei meinem Hoster 1&1 auf PHP 7 gewechselt hab. Naja, einen Versuch ist es wert. Im 1&1 Controlcenter, unter Hosting -> PHP Einstellungen kann die PHP Version nicht nur hoch, sondern auch runtergesetzt werden. Bitte unbedingt vorher ein Backup machen.

Nach der Umstellung auf PHP 5.6 ging auch die Anmeldung wieder, der Login Loop weg und auch die Clients synchronisieren wieder.

Laut https://github.com/owncloud/core/pull/24343 und https://github.com/owncloud/core/pull/24344 soll das Problem in kommenden oC Versionen behoben werden.

Also, wie gesagt: „Wenn du zu blöd bist….“

PS 17-01-21: Scheinbar hat sich das mit einem der letzten Updates geklärt. Jetzt funktionieren Owncloud und PHP 7 prächtig.

0 Comments

Submit a Comment

Deine E-Mail-Adresse wird nicht veröffentlicht.